TGPForums.com

  • July 17, 2018, 01:54:45 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search
Pages: 1 [2]

Author Topic: Desperately need help with brakes  (Read 4390 times)

0 Members and 1 Guest are viewing this topic.

meltboy11

  • Site Sponsor
  • Boosted
  • *
  • Offline Offline
  • Posts: 656
Re: Desperately need help with brakes
« Reply #15 on: May 18, 2015, 09:49:58 AM »

Well this is the first time he has ever told me it's not something he would do. He said he just doesn't do ABS.

I will PM my e-mail.

Whenever I press the brake pedal the red brake light comes on. The ABS light has pretty much flashed the entire 8 years I've owned the car, but has never presented a problem. It has always stopped exceptionally well up until this problem occurred.

The pedal seems pretty stiff for about the first 40-50% of the press, then, as if pressure builds up, it goes the rest of the way as normal and braking at that point feels normal.

The car does stop, just not nearly as fast as it should.

No strange noises.

Are you near Syracuse? I am only about an hour away from there out Utica way.
« Last Edit: May 18, 2015, 09:51:03 AM by meltboy11 »
Logged
90 TGP ~70k miles 5/15
04 Wrangler 4.0 5 spd
Litchfield, NY

mfewtrail

  • Administrator
  • Boosted
  • *
  • Offline Offline
  • Posts: 2122
Re: Desperately need help with brakes
« Reply #16 on: May 19, 2015, 08:14:20 AM »


Hey Matt, I am getting an error saying that the attachment directory isn't writable.


Also, I am fairly active on W-Body.

I'll relay the message to Luke. I noticed the attachments didn't work quite a while back. In the meantime, I suggest uploading images to imgur.  They'll stay hosted for quite a long time and allow direct linking. You don't have to sign up for the site, just upload in any image format, then paste the links here.  ;)
Logged
'93 SE, '90 Black/tan TGP, & '90 Red/tan TGP

meltboy11

  • Site Sponsor
  • Boosted
  • *
  • Offline Offline
  • Posts: 656
Re: Desperately need help with brakes
« Reply #17 on: May 20, 2015, 06:13:05 AM »

Ok so I was reading about crossing pins A and H on the ALDL connector to read ABS codes. So I get in my car and go to do this when I notice. I have nothing on the H. I only have gold on A and M and silver on the B and J as shown in the image below. A starting top right to F top left, then G to M bottom left to right. I didn't know if I should just try A and J, as I didn't want to short something out and cause more damage. I am really hoping it is just the accumulator and not the pump. I am going to try to get a junkyard one first before spending $150 on a new one and having it not even be that.


What cars would have the correct accumulator? 88-91 W bodies with ABS I assume. Anything else?






Logged
90 TGP ~70k miles 5/15
04 Wrangler 4.0 5 spd
Litchfield, NY

Heartbeat1991

  • TGP Driver
  • *
  • Offline Offline
  • Posts: 158
Re: Desperately need help with brakes
« Reply #18 on: May 20, 2015, 07:04:56 AM »

I wouldn't jump random terminals. 


I don't know where you found a new one for $150.  Accumulators have been hard to find for this car.
Logged

meltboy11

  • Site Sponsor
  • Boosted
  • *
  • Offline Offline
  • Posts: 656
Re: Desperately need help with brakes
« Reply #19 on: May 20, 2015, 07:42:41 AM »

I wouldn't jump random terminals. 


I don't know where you found a new one for $150.  Accumulators have been hard to find for this car.


Yea the electrician in me told me not to do it... lol


I found it at GMpartsdirect.com part number 88927271.
Logged
90 TGP ~70k miles 5/15
04 Wrangler 4.0 5 spd
Litchfield, NY

Heartbeat1991

  • TGP Driver
  • *
  • Offline Offline
  • Posts: 158
Re: Desperately need help with brakes
« Reply #20 on: May 20, 2015, 11:46:39 AM »

I found it at GMpartsdirect.com part number 88927271.




Good Luck with that.  They almost always refund your money and say "sorry, we don't have any."
Logged

meltboy11

  • Site Sponsor
  • Boosted
  • *
  • Offline Offline
  • Posts: 656
Re: Desperately need help with brakes
« Reply #21 on: May 20, 2015, 01:45:02 PM »




Good Luck with that.  They almost always refund your money and say "sorry, we don't have any."


boooooooo.... ok thanks for the heads up. At least I have a part number, I might have luck with it elsewhere.
Logged
90 TGP ~70k miles 5/15
04 Wrangler 4.0 5 spd
Litchfield, NY

Heartbeat1991

  • TGP Driver
  • *
  • Offline Offline
  • Posts: 158
Re: Desperately need help with brakes
« Reply #22 on: May 20, 2015, 04:11:35 PM »

If you do, please share here where you get one. 
Logged

meltboy11

  • Site Sponsor
  • Boosted
  • *
  • Offline Offline
  • Posts: 656
Re: Desperately need help with brakes
« Reply #23 on: May 20, 2015, 06:01:40 PM »

Nothing at the junkyard. I guess I just realized that first gen w bodies are now 25 years old... lol


I'll try a couple others this weekend if I get time. I wanna keep looking online.
Logged
90 TGP ~70k miles 5/15
04 Wrangler 4.0 5 spd
Litchfield, NY

Heartbeat1991

  • TGP Driver
  • *
  • Offline Offline
  • Posts: 158
Re: Desperately need help with brakes
« Reply #24 on: May 20, 2015, 06:09:37 PM »

Not easy to find in a junk yard.  Search that part number.  A few places pop up, but you'd have to call them and find out if they really have one.
Logged

meltboy11

  • Site Sponsor
  • Boosted
  • *
  • Offline Offline
  • Posts: 656
Re: Desperately need help with brakes
« Reply #25 on: May 20, 2015, 06:31:36 PM »

I saw Mfewtrail posted on w-body.com with a part number of 25528382 and also this, http://spinningwheels-sc.com/hydacaccumulatorballs.aspx on this post, http://www.w-body.com/showthread.php/79570-Sluggish-brake-pedal/page2?highlight=accumulator+part+number about halfway down.


I will check on that option too.
Logged
90 TGP ~70k miles 5/15
04 Wrangler 4.0 5 spd
Litchfield, NY

Heartbeat1991

  • TGP Driver
  • *
  • Offline Offline
  • Posts: 158
Re: Desperately need help with brakes
« Reply #26 on: May 21, 2015, 07:44:01 AM »

Spinning wheels sells a Hydac unit made for Thunderbird turbo coupes.  I wouldn't use one if you don't have to.  They don't screw on the same way.  I had one on one of my TGPs.  After a couple months, it blew off, and my car was sacrificed to the gods.  Burned right to the ground.  I'm sure there is a thread somewhere here.  I know there's on on w-body.


http://www.w-body.com/showthread.php/80178-Well-This-sucks


Somewhere I had pictures of the difference in the threads.  Spinning Wheels has also been out of stock for about a year or so.
Logged

meltboy11

  • Site Sponsor
  • Boosted
  • *
  • Offline Offline
  • Posts: 656
Re: Desperately need help with brakes
« Reply #27 on: May 21, 2015, 08:04:24 AM »

Holy crap that's brutal. That sucks.
Logged
90 TGP ~70k miles 5/15
04 Wrangler 4.0 5 spd
Litchfield, NY
Pages: 1 [2]
 

Page created in 0.055 seconds with 24 queries.