TGPForums.com

GENERAL => Problems & Solutions => Topic started by: blk90tgp on August 10, 2015, 09:41:15 AM

Title: Need help/ideas with stalling issue Please!!
Post by: blk90tgp on August 10, 2015, 09:41:15 AM
Hello, I have a 90 TGP with 71,000 on it. It has a Jeff M crossover pipe, TG160 chip, and K&N filter, everything else is stock. The car runs great, for the most part, but has a hard time idling and stalls allot. Sometimes it will even stall while driving it (coasting down hill) or coming to a stop. Even in park it will only idle for a short time before stalling. I've done a search for stalling problems and have read through every thread to get some ideas, and checked all the common stuff. I've replaced the IAC, cleaned the throttle body, replaced the o2 sensor, checked for vacuum leaks, idle re-learn etc. It seems like the computer learns the idle ok but as soon as it goes closed loop, the problem begins. If I unplug the o2 sensor, causing the computer to stay in open loop, the car idles perfectly and would run all day in park or driving around. As soon as I plug in the o2 sensor and the computer goes into closed loop, the engine runs a little rough at any rpm, like a slight miss in the sound of the exhaust, but that is intermittent. Unplug the o2 and it's smooth as can be with perfect idle and no stalling. I'm leaning towards the ecm being the problem, but don't have one to swap in as a test. Before I commit to buying an ecm, I would like to hear any suggestions from other TGP owners. I have checked all the grounds, car has a new battery, TPS checks ok and was replaced a while back. The new o2 sensor is the AC Delco, and acts the same as the one that came off.  I am trying to sell the car but this stalling problem isn't helping me at all. Please offer any suggestions you may have. Thanks!
Title: Re: Need help/ideas with stalling issue Please!!
Post by: Heartbeat1991 on August 13, 2015, 07:56:06 AM
I agree that it could be the ECM.  Does it have a 160 thermostat in it?  Try taking that chip out and run it stock and see if that makes a difference.
Title: Re: Need help/ideas with stalling issue Please!!
Post by: blk90tgp on August 14, 2015, 06:19:01 AM
It does have the 160 thermostat. I can swap in the original chip when I find "the safe place where I put it"  I have never had the plenum off, so is there a way to check for vacuum leaks of the lines going to the throttle body? I have a vacuum pump with gauge. Do these lines go to things with diaphragms that should hold a vacuum? I'm guessing that one goes to the fuel pressure reg, so probably yes to that, but what about the others.
Title: Re: Need help/ideas with stalling issue Please!!
Post by: Heartbeat1991 on August 14, 2015, 08:02:28 AM
The stock chip isn't piggybacked onto the TG160?
Title: Re: Need help/ideas with stalling issue Please!!
Post by: joec on April 11, 2016, 08:45:12 AM
I have the same problem with my 90 TGP, have you fixed the problem? was it the ECM? please let me know what fixed the closed loop problem.
Title: Re: Need help/ideas with stalling issue Please!!
Post by: meltboy11 on April 25, 2016, 05:42:20 PM
I'm leaning towards ecm too