TGPForums.com

  • July 17, 2019, 04:57:16 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search
Pages: [1] 2 3 ... 10
 1 
 on: April 26, 2019, 09:42:16 AM 
Started by atikovi - Last post by atikovi


One of the few 4 door rear drive GM cars left. Listed on Ebay at: https://www.ebay.com/itm/2008-Pontiac-G8-with-FREE-DELIVERY/153464574503?hash=item23bb339227:g:5vwAAOSwKVtcpWo9

 2 
 on: February 26, 2019, 02:17:43 AM 
Started by mfewtrail - Last post by killinprixs
HOLA !!!!!!!!!!!!!! LOLLLLLL

 3 
 on: February 26, 2019, 02:14:52 AM 
Started by Tgprob426 - Last post by killinprixs
when my TGP was stock , yes injectors left me stranded .    sounds like you checked just about everything else .

pop off the upper intake and ohm the injectors ,  a drastic reading will indicate you have a bad one ... or more.  Injectors are the first things I would replace with any TGP.   

do a continuity test from the cranks sensor wire to the ignition control module , otherwise your CPS wont be doing much.

The tach and radio in these cars are known to be very problematic in various ways so im not sure I would blame that yet for your engine not running right.

 4 
 on: January 08, 2019, 06:23:08 PM 
Started by Tgprob426 - Last post by Tgprob426
I have a 89 tgp. Car was running great then started stalling around 3000 rpm. Got it home barely. Then was hard starting then wouldn't start unless sat for a while. When through everything. Good fuel pressure clean exhaust. Changed all the electronics 1 at a time trying to fix. Tps, crank sensor, egr, control module, coils, o2, map, and ecu. Nothing worked. Also after I changed the ice and coil packs, the tach stopped working and now the radio doesn't respond. Only stays at 1:00 and can't tune or change volume etc, its like its frozen. Car will start after a while idle then dies. I give it gas it dies usually too even below 3000 rpm. Any ideas??? Prom chip? Ita strange that the tach and radio now have problems. Never had problems before, please help I'm at my witts end. Injectors? It seems to be electrical since the other issues.

 5 
 on: June 21, 2018, 09:33:31 PM 
Started by pontiacjeff - Last post by pontiacjeff
Does anyone have a turbo laying around? I need a good core, no shaft play, spins ok, no damaged wheels... to rebuild and use in a twin turbo project. Text or call me. 404-394-5776.

 6 
 on: April 02, 2018, 09:06:41 AM 
Started by Ruggels - Last post by Ruggels
Sorry about the delay had a lot of things to do to get my new vehicle up and running with reg and all that good stuff but now can turn my attention back to this the vehicle is located in sacramento CA and i ended up purchasing it back from insurance. I am glad to see some decent responses i would definitely like this car to go to an enthusiast..

besides the obvious body damage everything in the car works besides one window regulator (have the new one just didn't get around to changing). the sliding back function of sunroof (used to work it seems like its just binding). and a crack in the dash

trying to figure how to upload pics the file type they save as on my comp cant be uploaded ill try my phone

 7 
 on: April 01, 2018, 10:43:56 PM 
Started by Ruggels - Last post by Heartbeat1991
Still no response?

 8 
 on: March 25, 2018, 07:50:33 AM 
Started by Ruggels - Last post by bake82
Agreed.  Pics location.  Also as nick said post on w-body.com.   

I could be interested in motor and accessories...

 9 
 on: March 15, 2018, 02:51:02 PM 
Started by Ruggels - Last post by Dark Ride
Wouldn't mind having a parts car.  Like nick said need location and pictures.

 10 
 on: March 12, 2018, 09:35:11 PM 
Started by Ruggels - Last post by TGP Nick
Location and pictures would be helpful.  Also, this forum is pretty dead these days, so I'd recommend posting over on our sister site, w-body.com as well.

Pages: [1] 2 3 ... 10

Page created in 0.029 seconds with 19 queries.